Forum: Hardware Technical Support - Topic: Traktor Kontrol X1 - Page: 1

Use this forum if you have any question or difficulty using a USB or MIDI controller.
For general troubleshooting and controller configuration, please see Config & Troubleshooting.
(for problem with VirtualDJ 8, please use the dedicated VirtualDJ 8 Bug Report forum)
VirtualDJ forums
Hardware Technical...
Traktor Kontrol X1

Page : [>] [>>]


Author - Topic: Traktor Kontrol X1 -

docshuck
PRO Infinity
Member since 2009

Posted Sat 17 Jul 10 @ 5:19 pm
Does anybody know if the Traktor Kontrol X1 is compatible with VDJ? or is there even a way to make it compatible? Likewise, i'm looking into getting a controller to control a bunch of stuff. What would be my best bet if Traktor Kontrol X1 isn't compatible. I'm only looking at spending maybe $400 max.

pOpYDJ
PRO Infinity
Member since 2006

Posted Wed 06 Oct 10 @ 5:41 am
Yes it is completly compatible until now.

I have made a mapper:

http://www.virtualdj.com/addons/12019/NI_Kontrol_X1_def_mapper_incl__LEDs.html

It also support leds :-)

cu
pOpY

Q'damah
Home user
Member since 2011

Posted Wed 09 Feb 11 @ 6:31 pm
i cant download the mapper.. any chance someone can send it to me in an email. pleeeeeeeeeeease i spent a lot of money i just wish it was worth it
Posted Thu 10 Feb 11 @ 6:48 am
As advised in your other post, mappers and other add-ons are only available to registered licensed users who have purchased VirtualDJ Professional: http://www.virtualdj.com/buy/index.html

Nobody will illegally send this add-on to you.

Darkcomet112
PRO Infinity
Member since 2011

Posted Fri 07 Oct 11 @ 7:29 pm
Hi everyone.
Having a little trouble installing this whole thing.
Mind helping me out??

Joynt
Home user
Member since 2009

Posted Thu 13 Oct 11 @ 10:05 am
i have licens but I can not see anything link ......:(
Posted Thu 13 Oct 11 @ 10:17 am
Sorry, as clearly posted above, mappers are only available to registered licensed users of the full VirtualDJ Professional.

You only have VirtualDJ LE (Limited Edition), which is free limited software and does not support using custom mappers. It only supports and will work with the MIDI controller that it came with - In your case, the Hercules DJ Console MK2.

You can upgrade at a discount to the full VirtualDJ Professional by going to: http://www.virtualdj.com/buy/index.html

pOpYDJ
PRO Infinity
Member since 2006

Posted Thu 13 Oct 11 @ 1:41 pm
Please also dont try to get the mapper from me over PM or email.
I dont support warez, so i dont send out the mapper with an email!!

cu
pOpY

DJ Goasis
Home user
Member since 2011

Posted Sun 23 Oct 11 @ 3:15 pm
Hi,
I bought an TRAKTOR X1 last year and whenever I used it for more than 3 hours I had the same result in my lap tops.
I 've got a problem on hard disc twice on 2 different lap tops.
Whenever I tryied to use my TRAKTOR X1, I had a serius problem on hard discs and I replaced them.

I am still not sure if the fault is coming from TRAKTOR X1 or is something else but I have strong suspicions that it is from TRAKTOR X1. because I have excluded all the others.

Please lead me to find out where is the problem and tell me if it is possible to send it to the company to investigate if it has a problem.
As you understand, I cannot continue using it on doubt, cause of creating problems on my hard disks.

P.S. the TRAKTOR X1 seems to be functional and I 've never found something wrong with it, except these 2 cases but they are enough to persuade me that there is something wrong because these were the only 2 cases that I used the TRAKTOR X1 more than 3 hours and in general I use it rarely!

pOpYDJ
PRO Infinity
Member since 2006

Posted Mon 24 Oct 11 @ 5:30 am
I am running X1 over a year now without any problem.
Ill think there is something wrong with your notebook!

cu
pOpY

ch2n0kh
PRO Infinity
Member since 2011

Posted Thu 03 Nov 11 @ 8:56 pm
Hi pOpYDJ,

I downloaded your mapper and followed your instructions, nevertheless I can't make the damn thing work. I can only map Volume 1 to deck 1 eq_high, but if I try to add another mapping the eq_high one is forgotten. Also, Volume 2 and 3 (on both sides of X1) always move Effects P.1 on both decks (with the mapping xml provided in your bundle). I am using Controller Editor 1.4.2 and the version 3.00 of the X1 driver.

What am I doing wrong? or do you have any idea of why it is not working?

Any help would be greatly appreciated.

Thanks.

P.S. Has anybody else experienced this?

pOpYDJ
PRO Infinity
Member since 2006

Posted Fri 04 Nov 11 @ 6:46 am
Hey.

Ill think you do not map the buttons correctly in VDJ.
I dont have a VDJ installation here at the moment.

You must press "Add" or "New" and then move or press slider/button you want.
If VDJ is jumping to another entry of the list you have already mapped it!

X1 works since i have released my mapper very stable on my setup.

cu
pOpY

DJ Ross M
PRO Infinity
Member since 2004

Posted Thu 01 Dec 11 @ 6:02 am
Can I just check, should this work out of the box on a MAC.

I have my X1 working with Traktor.
Close Traktor.
Switch to MIDI mode, but it doesn't seem to work (Definition and Mapper are both present.)
Nothing seems to work.
If I try to map the controls to a different controller it works.
If I select Kontrol X1, nothing works.

Am I missing something?!

Thanks,

Ross

DJ Ross M
PRO Infinity
Member since 2004

Posted Sat 03 Dec 11 @ 9:53 am
OK so I got the controller working (seems another controller definition was causing problems)

Now I just need to work out why the LEDs are not working...

I'm on MAC if that makes any difference.

Ross

pOpYDJ
PRO Infinity
Member since 2006

Posted Sun 04 Dec 11 @ 7:32 am
Hey.

Yes it makes a difference. The MIDI Driver IN and OUT names are different.
Please take a look in the definition file. on the in the line with the mapper name / creator .... there should be no tag drivername= or drivernameout=.

Please check this.
Good luck
pOpY

PS: Sorry but I have no MAC to test my mapper :-(

DJ Ross M
PRO Infinity
Member since 2004

Posted Sun 04 Dec 11 @ 8:36 am
I don't remember seeing those tags so I looked again, they are not there...

pOpYDJ
PRO Infinity
Member since 2006

Posted Sun 04 Dec 11 @ 12:32 pm
Maybe you look at your mac system and took drivername and drivernameout and wrote those tags in the definition file.
Maybe then it works !?

cu
pOpY

liltego
PRO Infinity
Member since 2011

Posted Wed 01 Feb 12 @ 3:55 pm
i just bought the kontrol x1 i downloaded the mapper for it and followed the instruction that came with it .Am using a mac and vdj 7 pro and the ns6 the only thing that is working on the x1 is the browser knobs and the loop knobs but rest of the buttons are not working am i missing something .

cantalien
PRO Infinity
Member since 2008

Posted Sun 04 Mar 12 @ 2:30 pm
pOpYDJ wrote :
Hey.

PS: Sorry but I have no MAC to test my mapper :-(


The leds of Kontrol X1 does not work on a MAc. Anybody would have a solution?


technz
PRO Infinity
Member since 2011

Posted Sun 25 Mar 12 @ 4:53 am
i may be able to get my hands on a mac and test pOpYDJ's mapper and modify it so it is able to work on a mac

Page : [>] [>>]