Forum: Old versions

For older version, like VirtualDJ 7.


NOTE: VirtualDJ 7 is not maintained anymore.
Topic: Error in the sound driver [VDJ PRO 5.2.1 + Hercules RMX] [SOLVED] - Page: 1

This part of topic is old and might contain outdated or incorrect information

Hi there,

I'm having this hugly error saying "error in the sound driver". I tried the fixes related in this topic here.

I don't understand what's going on.
I have all my drivers up to date (RMX Firmware: V1.1.29.6 - VDJ PRO: 5.2.1).

I was using everything without problem at all up to some days back, and by now, I can't use the RMX Console anymore, as when I try to select in the Sound card config, it always crash with this error.

Can you help me?

Thanks in advance.

Posted Sat 20 Sep 08 @ 12:04 pm
spinnaJPRO InfinityMember since 2004
What is ur sound setting now?

Posted Sat 20 Sep 08 @ 12:08 pm
I'm trying to use the DJConsole RMX as the SoundCard, with everything as simple as it can be. It has always been working before, so I really mind why it's not working anymore.

Posted Sun 21 Sep 08 @ 6:13 am
spinnaJPRO InfinityMember since 2004
Reset to factory setting and delete the preferences file. Then close n open up again VDJ. If this do not werk, try to use different USB port on ur mac. Also are u on tiger or leopard?

Posted Sun 21 Sep 08 @ 6:25 am
I already tried it (deleting pref file + changing usb port)...but it does not help !

I'm on Leopard, with the latest updates.

Hope this as nothing to do witht the latest major updates...

Posted Sun 21 Sep 08 @ 9:28 am
spinnaJPRO InfinityMember since 2004
Ok check in the remote tab in VDJ n see whether the rmx is activated. See whether the mk2 icon is green.

Posted Sun 21 Sep 08 @ 10:19 am
RMX Activated and "green light"...sounds more and more strange, isn'it? ;-)

Posted Sun 21 Sep 08 @ 10:25 am
spinnaJPRO InfinityMember since 2004
Ok. Now close vdj n reboot ur mac with the rmx attached.. and it should be ok;)

Posted Sun 21 Sep 08 @ 10:44 am
I rebooted and then...the same :-s

Posted Sun 21 Sep 08 @ 12:44 pm
spinnaJPRO InfinityMember since 2004
hmmm...if u dun mind can u tell me ur sound config?

input- output and so on..

Also do u use herc rmx aggregate driver in ur config?

Posted Sun 21 Sep 08 @ 2:07 pm
xonorPRO InfinityMember since 2005

Posted Sun 21 Sep 08 @ 2:26 pm
@spinnaJ: I really use the most basical settings...nothing really "innovative" in my configuration.

@xonor: already tried it, but the same hugly error...

Posted Mon 22 Sep 08 @ 11:44 am
spinnaJPRO InfinityMember since 2004
Check your PM n add me in msn.

Posted Mon 22 Sep 08 @ 1:34 pm
I've got exactly the same problem. Everything worked perfect. But then after I installed the latest update from Leopard (10.5.5) I got a sound driver error! I get the error with both the CD version of Virtual DJ DJC and the update (5.2) version from the website. I've tried everything to make it work but I get the same sound driver error over and over again. I'm really frustrated. Do I have to wait for a new update of VirtualDJ to make it work again??

Can someone help me?

Posted Mon 22 Sep 08 @ 5:44 pm
Thanks SpinnaJ for your search...I tried everything related to your tricks, but that does not help...

snif snif...

Posted Tue 30 Sep 08 @ 12:00 pm
spinnaJPRO InfinityMember since 2004
Tempo have u sorted this?

Sorry can't be much assistance these day as been bz right now.


Posted Thu 02 Oct 08 @ 11:01 pm
Hey there ;-)

Sorry for my late reply !

But Yes, I finally sorted it out !!! I contacted the VDJ support, and they simply told me to use another sound configuration, so here is the conf:
You simply have to choose the "4-out card" in the soundcards, and then selects the Hercules RMX in the field "driver 1", and then I select the output channels as "Master: chan 1&2 Headphones : chan 3&4"...

And then it works just fine !

For the moment, this solution is OK, but I hope it has nothing to do with lack of sound quality or less usability of my Hercules RMX...I will test further on and revert ;-)

Thanks anyway for your helpful help SpinnaJ :-D

Posted Sun 05 Oct 08 @ 2:42 pm
spinnaJPRO InfinityMember since 2004
Hi tempo glad u sorted it;)

Anyway up in the post if u have stated what is ur sound config as i have asked maybe we can solve it earlier.. hehe:P

spinnaJ wrote :
hmmm...if u dun mind can u tell me ur sound config?

input- output and so on..

Also do u use herc rmx aggregate driver in ur config?


temporer wrote :
@spinnaJ: I really use the most basical settings...nothing really "innovative" in my configuration.


Regards;)

Posted Sun 05 Oct 08 @ 11:36 pm
Yeah sure, but it really sounds "basical" to me to use my Hercules RMX as the master soundcard, isn't it?

Anyway, thanks a lot ;-)

Posted Mon 06 Oct 08 @ 12:15 pm
xonorPRO InfinityMember since 2005
Basical?

I use my RMX as the master sound card.
Where are you trying to get the master sound? From the speakers of the mac?

RMX and MK2 are "all in one" controller, with proffesional conectors and "mid/high" quality sound card.

Anyway, i'm glad that you have solved your problem.

Posted Mon 06 Oct 08 @ 1:15 pm
Page : [>] [>>]
34%