Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: ECHO effect on DDJ 1000 not working properly - Page: 1
matto_PRO InfinityMember since 2007
Hi,
I just got ddj 1000 and I notice that ECHO effect is not working properly. It's works with fader on, but when I put fader down than immediately mute. Normally ECHO repeats to the end (as is set), but with this ddj 1000 not.

Can I somehow change this setting, that echo will work to the end even if I put fader down?

Thanks

Posted Tue 08 Jan 19 @ 8:11 am
Normally your set fxProcessing to post-fader in the settings

But since the DDJ-1000 works in external mixer mode, so that VDJ doesn't really handle the mixing, I'm not sure that will work...

Posted Tue 08 Jan 19 @ 9:03 am
matto_PRO InfinityMember since 2007
Yes, if I connect for example cdj1000 and put some channel to LINE, than DDJ-1000 works in external mode and ECHO works great (as it should).
Can I set that all mixer section works as external mode and players as VDJ? If this is possible then will be the best.

Posted Tue 08 Jan 19 @ 5:24 pm
matto_ wrote :
Yes, if I connect for example cdj1000 and put some channel to LINE, than DDJ-1000 works in external mode and ECHO works great (as it should).

Yes, that's because when no software is preset, the DDJ-1000 changes into using hardware effects. It's the same with/without Rekordbox software

matto_ wrote :
Can I set that all mixer section works as external mode and players as VDJ? If this is possible then will be the best.

No, when you set VDJ to external mode, it's the physical faders on the controller that does the mixing. And since they physically cuts of the audio, there is not much VDJ can do to "go through" them and let echo have a "tail" like you would like...


Posted Tue 08 Jan 19 @ 6:01 pm
matto_PRO InfinityMember since 2007
Now I tryed with Recordbox program and with normal line-in. In both beat FX works normal. Only in VDJ not working with a tail.

I made short video with recordbox, line-in and with VDJ:
https://drive.google.com/open?id=1Lip5XT_2EYNDAm7-iuWmsf1uW_GWe6Vn

This is really strange that is not working as ECHO FX works from a begining. For me it is looks like a bug in beat fx section. Funny thing is that all other things works just fine.

Posted Fri 11 Jan 19 @ 10:21 pm
Hi,

I have a DDJ-1000, and i've modified :

FX processing -> to post-fader in options (general options of Vitual DJ)

And i've changed the "Trailing stop" in the settings of the ECHO (parameters), for each Deck and Master.

And ECHO work and behave like a charm, like fx in Rekordbox.

I would like just a second ECHO (ECHOS2) in the list to simulate low cut echo with a Hipass Parameter in te settings of echo at 6000 Hz or 1000 Hz.
(It's a possible to duplicate internal FX ? to have different settings ?)

I use Virtual DJ with DDJ-1000, because REKORDBOX doesn't normalize correctly track with AUTO GAIN, and not normalize peak, but make an hidden compression per DECK before limiter clipping/ (Change the original AUDIO of a file, not inside the file but with Analyse information and Software).

The sound quality of Virtual DJ is great with DDJ-1000, but you have to disable the master volume in the Defaut midi factory settings. Because DDJ-1000 control the Master Volume by hardware, no need to change the DIGITAL LEVEL between VIRTUAL DJ and DDJ-1000. (i set the volume of VIRTUAL DJ to the MAX, and is not controlled by midi by the VOLUME KNOB of the DDJ-1000, to have volume bit-perfect to the DDJ-1000 DAC, and not change the DIGITAL AND ANALOGUE VOLUME in same time)
So it's an error in the midi Factory default for DDJ-1000, included in Virtual DJ

VIrtual DJ sound much better than Rekordbox V5.4.x :), with a good float 32 bits engine, and good Normalization of the Track (after auto analyse of Tracks, not before)
Much better than Rekordbox.

DDJ-1000 sound 50% better with a non pioneer software. Strange ?

And i wad tired to wait Rekordbox Lighting update, or Fix.

Soundswitch ordered to replace RB-DMX1, because i will don't use Rekordbox anymore, because of bad Track peak normalization (Compressed instead), and bad -9dB or other settings Headroom of Rekordbox...

Virtual DJ 2018 is the Winner :)

If Pioneer fix the audio quality and update lightings, i will use again Rekordbox :) But their support is very rude, and don't believe several users that have found this audio compression problem, in the Software, not the hardware :)

Regards,

O.


Posted Sat 12 Jan 19 @ 11:29 pm
Interesting info thanx for sharing.
Regarding main volume I will try to also change that on my DDJ-1000 mapping.
But did you really get the post fader echo fx to work?
I thought the DDJ-1000 works in external mix mode?

Posted Sun 13 Jan 19 @ 11:47 am
Only in internal mode, Controller midi+Audio

Posted Sun 13 Jan 19 @ 7:49 pm
matto_PRO InfinityMember since 2007
yes this is what I looking for! Thank you Oliver. I can not believe that it was solved whit only one click. Now works perfectly. It is strange that is not default, but ok now we have a solution.
And disable of Master volume! Now is really better sound. I almost return ddj-1000 to shop because of not so good quality of sound :) Great and very important tip! I try to disable also GAIN, but this not works by hardware.

Quote :
And i've changed the "Trailing stop" in the settings of the ECHO (parameters), for each Deck and Master.

I can not find this. Where can change this setting?

Posted Sun 13 Jan 19 @ 9:18 pm
Hi,

For example, choose ECHO effect in one Deck with the mouse, click on the Arrow near the name of the effect, you will have a list, focus mouse on ECHO effect, and the settings gear will display, click on this gear, and down you will see a lot of parameters fo echo, with a "trailing stop" option…

You can even simulate the "low cut echo", with a high pass filter setting.

Yes, when you plug the DDJ-1000 in Virtual DJ , it will be nice to have post FX and Trailing stop, as default setting, thant the FX behave like hardware.

Sorry for my poor English.

Regards,

O.

Posted Sun 13 Jan 19 @ 10:56 pm
serieBPRO InfinityMember since 2017
Really nice tip about the Master Volume guys. I have tried to disable but I'm not confident if I did it right:
In options over the factory mapping going to the button MASTER VOLUME and leaving in blank the action is the way to disable?
Thanks

Posted Mon 14 Jan 19 @ 1:28 am
Hi,

i've edited my DDJ-1000 custom mapping, with NOTEPAD++ :

(Windows en français, mais en Windows English, the name of folders could change...)

D:\Mes documents\VirtualDJ\Mappers\Pioneer DDJ-1000....................

Juste delete the line with Master Volume (don't need to do this for gain and others, that it's internal software controlled)

Posted Mon 14 Jan 19 @ 8:12 am
May anyone from the VDJ team chime in and comment on this great findings. Can this be updated in the next build ?

Posted Mon 14 Jan 19 @ 8:38 am
AdionPRO InfinityCTOMember since 2006
The default mapping of the DDJ-1000 has "fake_master on" in ONINIT, which is there exactly for this reason.
What it means is that VDJ does not internally apply master volume, and the knob on VDJ is there only for visual confirmation of the controller's level.
As long as you don't remove this from ONINIT, there is no need to remove master_volume from the mapping, as it is used only visually anyway.

Posted Mon 14 Jan 19 @ 9:20 am
Thanks Adion for this clear reply. So the change is not needed and does not make any difference at all. (maybe placebo then...)


Posted Mon 14 Jan 19 @ 9:30 am
serieBPRO InfinityMember since 2017
Big thanks for the clarification pals

Posted Mon 14 Jan 19 @ 10:20 am
Please read carefully:

1) MASTER Volume knob is sending MIDI data on software, but this MIDI are not actually used to alter the volume of the software. These data are used only to "update" the master volume knob on VirtualDJ GUI.

2) DDJ-1000 offers HARDWARE controlled attenuation levels, a Peak Stop Limiter and a MONO/Stereo option.
These are all accessible from the special DDJ1K-Settings PAD Page.
Please read here: http://www.virtualdj.com/manuals/hardware/pioneer/ddj1000/settings.html#masteroptions
If you feel that your device does not sound as it should, it may worth to check these settings as they are stored in the device itself and Rekordbox DJ can also change them.

3) We have discovered that the latest Firmware 1.05 released in June 2018 from Pioneer has changed the way effects work with device.
We have prepared an update that will come this week to address those changes.
For this reason it's required that all users should re-create their default audio setup to remove fxprocessing lines from their audio configuration, and also use the updated default mapper.
A separate / special announcement will be made for these changes as soon as the update gets released.

4) Setting the fxprocessing engine to POST should be enough now, and if you really want to use POST fader effects you should disable the extra trailing sound option from the Echo effect.

Posted Mon 14 Jan 19 @ 2:08 pm
Hi,

PhantomDeejay, thanks for that !

It's very clear, and usefull :)

:)

I don't use the DDJ-1000 internal limiter, it's on off and it's on Stereo in Rekordbox DDJ-1000 settings menu.
Before to switch to VIrtualDJ

Anyway, VirtualDJ sound better than Rekordbox V5.4.x.

In Rekordbox, the limiter change AUDIO to early, and the sound is lifeless.

(But you are right, be aware of the mono/stero and limiter options for DDJ-1000 in Rekordbox, before using Virtual DJ)

Regards,

O.

Posted Mon 14 Jan 19 @ 2:19 pm
matto_PRO InfinityMember since 2007
Thanks for all these information and tips. In my settings were set to MONO - oh dear :). Every day is better sound with you guys.

And I already change manual some Beat fx, but you said that will be a new upgrade. Just awesome! Great work.

Posted Mon 14 Jan 19 @ 10:44 pm
Hi,

Early update in VirtualDJ settings on :

just auto downloaded/installed V8.3 b4742.

LOG update don't speak about DDJ-1000, but there are some changes for DDJ-1000 :

The DDJ-1000 factory default is much better and updated in V8.3 b4742 :

FX works now, but you have so set now pre fx in option , not post fx - And others good changes.

But in DDJ1K-settings : the option is set on MONO by default for master output, and booth output. (not STEREO)

(Checked with a phase test (Right/left/center) .wav file and with master VU meter)

The mono/stereo option doesn't route to headphone, have to check with speaker connected do master XLR/RCA out of the DDJ-1000 and Booth output.

It's dangerous


Can you fix this quickly ?

Thanks for this great work :)

Olivier

Posted Wed 16 Jan 19 @ 7:31 pm
Page : [>] [>>]
77%