Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: NI F1 controller MIDI
I try to use my F1 controller to generate midi data for freestyler DMX.
But it seems the F1 does not send midi as other controllers I have tested, for example AKAI APC mini, without any problem.
I use MIDI-OX to monitor midi data from F1 but it does not produce any.
Is it something I need to do in order to use the F1 as 'simple midi controller' ?

Posted Fri 04 Jan 19 @ 12:44 pm
I think you're asking on the wrong forum. :-)

A quick Google tells me the following:
The F1 should automatically enter MIDI mode when Traktor is not running. If it doesn't, then shift + browse will switch modes.

It's also mentioned in the F1 manual...

Posted Fri 04 Jan 19 @ 5:45 pm
Not wrong. I only use VDJ and therefore I try to get the answers here and it might also help others.

I beg on my knees, groovin that I am forgiven not finding this in the F1 manual. ;)


Posted Fri 04 Jan 19 @ 6:13 pm
706720PRO (OEM)Member since 2014
Another tip... Most if not all NI MIDI devices requires ‘Controller Editor’ to be opened before you can use them on Non-NI Softwares.

Posted Mon 07 Jan 19 @ 6:58 am
Where is this 'controller editor' found ? Pushing SHIFT + BROWSE does not change anything.
Maybe traktor is needed which I don't use or have.


Posted Wed 16 Jan 19 @ 1:42 pm
locodogPRO InfinityModeratorMember since 2013
Speaking from personal experience with the S4 (released around the same time), my unit does not send midi directly, it sends some sort of proprietary HID which is then translated to midi by a driver/trakor mapping app (controller editor is on the trakor site). Without the driver it won't work (I'm not sure about the F1)
I don't have to have controller editor running as when installed it adds some sort of driver/service to autostart.

As for the Shift + Browse, in the case of the S4 there's a knack to it, just after powering the unit, as the lights sweep on and don't hold on for too long.

Posted Wed 16 Jan 19 @ 2:11 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Before setting the device to MIDI mode, try to set it to "Ignore" from VirtualDJ (Settings->Controllers tab, select the "ignore" from Mappings)

Posted Wed 16 Jan 19 @ 4:04 pm
Thanks all for advice.
The F1 works perfect in VDJ, but I would try to use it to send midi to control freestyler DMX.
When hooking the F1 up to midiox there is no midi sent. But I will try the shift + browse combo during startup and see.

Posted Wed 16 Jan 19 @ 7:53 pm