Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: I have some issues with the SZ2
DJ SWIDPRO InfinityMember since 2009
First I have to say that i had the first SZ and he worked great with vdj8 but I don't feel the same with the SZ2, when i move the pitch up and down i get a sound dropout the jog display and the pads lights are flickering, if i move it fast the sound just gets cut off, i have a mbp retina 2015 i7 16gb and its not a cpu problem I checked in the activity monitor and the cpu doesn't even move when i move the pitch slide, even tried a new usb cable still the same. Second, the master lights gets really quick to the red lights when the master knob is only at 1 o'clock, same two songs same volume with serato and the master is in the start of the orenge lights.
My SZ2 is one week old I tested with serato and everything worked fine so I guess it's something with the mapping.
Mbp 2015 15 inch i7 16gb osx 10.10.5
Vdj8 last build
Thanks in advance

Posted Sun 28 Jan 18 @ 5:38 am
DJ SWIDPRO InfinityMember since 2009

Posted Mon 29 Jan 18 @ 11:42 am
djdadPRO InfinityDevelopment ManagerMember since 2005
For the LEDs refreshing, have you tried to reset VDJ to factory default settings ? (move/rename/delete settings.xml from /VirtualDJ folder and try again)
One setting that comes quickly in mind is the ControllersRefreshrate but others could be related as well such as custom mapping.

BTW, when you move the Pitch and you temporary lose the Jog illumination, have you noticed if other Leds act the same, such as Pads (use Slicer mode, which moves in time) , VU meters etc ?

Posted Mon 29 Jan 18 @ 12:18 pm
DJ SWIDPRO InfinityMember since 2009

Hey djdad, I made 3 fresh installs of the osx and vdj and its the same results, I updated the firmware last week to 1.04 and tried the two drivers with two separate osx 10.10.5 and 10.12.6 and still same problem, I made everything like the in manual of the SZ2 in vdj website no changes with the problem.
Yes the pads also flickers when i move the pitch.
I connected the SZ2 to my pc with windows 7 and everything works fine there.
If you need more videos just tell me...
Thank you

Posted Mon 29 Jan 18 @ 3:18 pm
DJ SWIDPRO InfinityMember since 2009
Fresh install means I deleted my macintosh hd and installed new osx and I did it twice 10.01.5 - 10.12.6
Also tried with another macbook pro same problem,
I tried 6 last builds same problem
I never touched the mapping at any time just plug and play.
If you think about the hardware using serato with the same macbook works great.
thanks again

Posted Mon 29 Jan 18 @ 4:44 pm
DJ SWIDPRO InfinityMember since 2009

Posted Mon 29 Jan 18 @ 6:42 pm
I had downloaded the free version of virtual then I purchased an used controller that came with the installation cd and key code but I am having a real hard time with it, no sound, it pop up to ask me to download the new version, it just does not work

Posted Mon 29 Jan 18 @ 8:28 pm
@DJ Swid:
What other devices do you connect on your MAC ?
Is SZ2 connected directly on a USB port or does it go through a hub ?

Technically I can explain to you why this issue occurs, but I don't think it will help you to eliminate your problem...

Anyway: The reason the controller leds are flickering is because SZ2 gets out of Serato mode (and then immediately it goes back in)
In order to maintain the Serato mode alive, the controller needs to be polled every few ms. If one of those poll messages fails to arrive within a predefined time window, controller exits Serato Mode.

In simple words this means that for some reason on your MAC the communication with the controller is problematic. Your MAC fails to keep a steady rhythm of sending MIDI data to the controller and that's why the controller resets Serato Mode every now & then.
You said that you formatted your MAC, but I would take a quick look on MIDI studio to ensure everything is fine there.
Also you said it works fine with Serato, implying that it's a VirtualDJ issue, and not a hardware one. Please check your controllerRefreshRate setting, and switch it to 0 if you have changed it.

Other than that, please try to think what might be different when you use VirtualDj and Serato now that you know where your problem comes for.
E.g ? Do you have Wi-Fi open with VirtualDj but closed with Serato ?
Generally try to think of any reason that could cause the MIDI communication to slow down and let us know...

Posted Mon 29 Jan 18 @ 8:47 pm
DJ SWIDPRO InfinityMember since 2009
Hey phantom, i have two mbp one 2015 the other 2012 both 15 inch i7, same problem in both of them.
I had SZ till last week I worked with him two years and it worked perfect with vdj with both mac's.
Between using vdj and serato I didn't change nothing, close one open another, wifi and bt are always off when I'm working.
The SZ2 connected directly to the mac and nothing else, the driver audio midi and midi studio all fine.
Also, Have you seen this video ?
Its not just the sound dropouts there is something with the volume of the line and the master, i cut the low eq the uv meter goes up to to the red instead of getting down.

Posted Mon 29 Jan 18 @ 11:46 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Few more questions/tries ..

If track is not playing and you move the pitch fader, do you get the same issue ? Is it related to how much is the PitchRange % set ? Or some certain Pitch %.. E.g. if it happens when you reach near the ends of the fader and the Pitch is at %25, if you set Pitch Range to 50%, does it still happen when you reach the same Pitch % or its ends ?

Is the latest Firmware 1.04 installed ? I see a change in the Pitch fader resolution in this update and the mapping files seem to use a 14-bit resolution already.

Can you also try to double the latency setting from VDJ->Settings->Options tab ?

The VU Meter issue could be related to the 1st one, since there is a "refreshing" issue in general, so here is what happens..
The red LED is showing the PEAK value of the Deck level and this takes a few msec/seconds to refresh (helps you keep an eye on the max current level). The LEDS are mapped as...
LED_VUMETER : get_limiter 'deck' ? constant 1.0 : get_level, which means that it will "fill" the VU Meters (constant 100%) if the VDJ Limiter kicks on the deck, and will indicate its level if not.
Can you try to ...
- map it as .. get_level
- see how it reacts if the VDJ setting zeroDB is set to -3db or -6db ?

Posted Mon 29 Jan 18 @ 11:53 pm
DJ SWIDPRO InfinityMember since 2009
I tried all pitch range no change
Change the latency to 64,128,256,512,1024 no change, even bit rate to 48 and 96
I updated the firmware to 1.04 last week
I changed the db from -1 to -12 and still the master volume stays in the red.
One more interesting thing, if two decks are playing and I'm moving the right deck pitch up and down and the headphones cue is open in line 1 i can hear the playing song in the left deck popping up in the master, even that the fader of line 1 is down.

Posted Tue 30 Jan 18 @ 12:58 am
djdadPRO InfinityDevelopment ManagerMember since 2005
One of our developers will email you shortly with instructions to follow.

Posted Tue 30 Jan 18 @ 6:53 am
mozssPRO InfinityMember since 2017
controller refresh rate on 0

it happenes even when the deck is not loaded

thank you

Posted Tue 30 Jan 18 @ 2:25 pm
DJ SWIDPRO InfinityMember since 2009
mozss wrote :
controller refresh rate on 0

it happenes even when the deck is not loaded

thank you

I answered from my friend account cause now we're tasting with his SZ2

Posted Tue 30 Jan 18 @ 4:18 pm
DJ SWIDPRO InfinityMember since 2009
Hey, any news about the solution for the problem ?

Posted Sun 04 Feb 18 @ 7:04 pm
DJ SWIDPRO InfinityMember since 2009
Any progress with the solution ?

Posted Wed 21 Feb 18 @ 3:29 am
OK... There are major issues with the ddj-sz2. If I load a track on deck 2 when deck 1 is playing a song, deck 2 Turns up 100% volume red line and literally blows my speakers. I had a ddj-sz1 for 4 years with no problems... what is going on?

Posted Sat 04 Aug 18 @ 11:59 am
djdadPRO InfinityDevelopment ManagerMember since 2005

Posted Sat 04 Aug 18 @ 3:18 pm
Thank you for replying. I am at home now so i cant verify, but isn't it configured this way by virtual dj after it detects sound card and asks you if you want to use it? I looked initially and it looks just like my sz setup.

Posted Sat 04 Aug 18 @ 5:19 pm
I have never seen viirtualdj do this before. I may grab my older laptop tonight and see if it's an issue with my OS and virtualdj. I did a repair with a virtualdj install after these events started occuring last night, but it still turned the volume to 100% (mains were red and channel went red) when I dropped a song in the opposite deck, randomly. Also, the controller acted as if it was a software mixer the entire time, like a ddj-sx or ddj-sb, ie: turn the knobs and not get a response until it reached a certain level in the software. The SZ1 never did this.

Posted Sat 04 Aug 18 @ 5:24 pm