Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: effects_used doesn't observe the it's deck.

This topic is old and might contain outdated or incorrect information.

locodogPRO InfinityModeratorMember since 2013
I'm trying this on a LED [4 actually 1 per deck]

effects_used & param_bigger 0 ? blink 250ms : off

but it seems the LED doesn't observe the it's deck assignment, so an active effect on any deck and they all light [ other scripts like, select ? blink 250ms : off work on the LED]

Is this the way it's meant to be, and I need to multi query device side?

*edit*

I can get this one, tried 'get effects used' tried adding deck X before it, tried wrapping Deck X in quotes, tried just X in quotes.

Posted Fri 12 Aug 16 @ 2:19 am
djdadPRO InfinityDevelopment ManagerMember since 2005
effects_used 'deck'

its in the description of the action and should return true if an effect is triggered on a deck, so you dont have to use the param_bigger either.

Posted Fri 12 Aug 16 @ 5:31 am
locodogPRO InfinityModeratorMember since 2013
Thanks for the reply, I misunderstood what the script info meant by 'selected deck' but I've think found a bug here

effects_used 'deck' ? blink 250ms : off

this works fine, until you have an effect active on master, then the light of the selected [ the deck picked by the script 'select'] deck blinks and all fxs on the deck are off.

Posted Fri 12 Aug 16 @ 5:54 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Ok, reported.

Posted Fri 12 Aug 16 @ 8:06 am


(Old topics and forums are automatically closed)