Forum: Old versions

For older version, like VirtualDJ 7.

NOTE: VirtualDJ 7 is not maintained anymore.
Topic: mapping an apc 40
hey guys wonder if someone can advise.

I'm trying to map my APC 40 with VDJ 8 and am having no luck..

I've tried several of the maps on here, and copy the files to the library/devices folder but when I try and map nothing gets recognised. Then if I try and map the device manually it's all over the shop, map volumes and the device I've mapped it to doesn't respond then the wrong deck responds etc etc.

None of the downloads in the add ons area are helping either..

any advice would be great, I'm lost :)

Posted Tue 07 Jul 15 @ 8:04 am
djdadPRO InfinityDevelopment ManagerMember since 2005
I am a bit lost too :)

the big question is...
If the Devices folder is empty, does the APC40 gets detected properly and works as epxected ?

Is there a detection issue ? If the unit gets detected properly, then you should see the unit in the CONTROLLERs tab and the "factory default" available in the Mappings drop down list.
Doesnt work as mapped originally ?
Having trouble to change the action of a button/slider/led ?

Lets leave the custom mapping out of the equation for now

Posted Tue 07 Jul 15 @ 6:17 pm
Sorry, original post doesn't make much sense does it! lol

well basically I've connected it up and it does identify the controller correctly when I go to map it (ie it doesn't do anything until I try and map it which I assume is the norm). The Factory Default setting provides no responses with all the inputs seeming to not be assigned. I select custom from the drop down and try to start mapping.

then I try to start mapping things and the crossfader maps no problem as do some of the knobs. Then I try to start mapping the channel volume which is where my problems start.

I can map a single channel / deck to a volume slider - but then when I try to map subsequent ones it starts to go wrong, with all controls operating one deck or no decks. Same for a lot of other buttons or if I try to map individual eq's

I tried to download other's maps from the download area to see if I could get some decent functionality but they either download as an installer and although 'installation complete' is shown, nothing changes - or if I drag the defination files downloaded into the devices folder, I still can't select the maps from the drop down if that makes sense? device is fully working as far as when I use a control it appears in the list at the bottom of the mapping page - there just seems to be an interface problem

Posted Tue 07 Jul 15 @ 8:54 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Goto CONTROLLERS tab and select the APC40 from the left side. From the Mappings list, choose the "Factory Default" and "Automatic" in the Deck assignment (if not already that way)
Do the pads trigger Samples ?

If not, we have a detection issue here and can provide further instructions, but will wait for your feedback.

If they do, then you need to know that since the unit is a "single deck" one, you will probably need to specify the deck to the assigned actions or else they will trigger the action to whatever deck is selected.
So if you want a Pad to trigger loop 1 in deck 2, you need to assign that as .. deck 2 loop 1 and not just loop 1

Posted Tue 07 Jul 15 @ 10:37 pm
firstly thanks for the replies, it's much appreciated :)

When I select Factory on automatic, five of the buttons work (triggering effects)

I've tried selecting deck 1 then assigning volume, deck 2 assigning the next volume control deck 3 etc, etc, but then when I go to test them, volume one moves deck one's volume, but then all other volume controls move deck one.. Almost as if it isn't acknowledging which deck I'm trying to map the control for if that makes sense?

same goes for any other controls I assign as far as cues, eq's play buttons, loops etc

Have been trying to do it by:

1) selecting APC40 on the left
2) Custom Mapping (when I select factory and make changes it switchest to custom anyway)
3) select deck
4)push putton, dial, slider I want to change so it pops up in the bottom left key learn section
5) select the function (either from the list or clicking the icon then clicking the function I'm after
6) save

7) repeat from 3

I suppose it's treating all mappings as whatever deck I select last as opposed to memorising the deck I made the changes on?

Hope that makes sense, I'm used to using my CDJ's as controllers rather than an all in one unit so still trying to get my head around it - had to down size to something a bit more portable for working interstate. Have seen it working but not quite sure what the trick was :)

even the LEDs etc are all working so doesn't feel far off..



Posted Wed 08 Jul 15 @ 6:46 am
progress! I found that manually entering where you'd enter a macro and inserting deck 1 and deck 2 seems to solve the problem for cues, just seems I have to manually enter it rather than using the dropdown but seems to work so far!

would be keen to hear any other suggestions though :)

Posted Wed 08 Jul 15 @ 7:23 am
Ok I'm going to piggyback on this topic for a moment. Currently having more issues than I expected when changing from vdj7 to vdj8 using my APC40.

Initially i did not want to swap while all the bugs were worked out of 8 as well as my mapping was reacting vastly different between the two versions.

I made the decision to test it out again after playing with the new "factory default" mapping VDJ has created for the APC40 and loving some of the features that are now mapped.
That being said, the factory default mapping leaves much to be desired as it is missing basic functions and also is not completely mapped even to the PDF used as reference.
For instance, the crossfader is not even mapped in the default although it's function is listed in the manual. Same goes for the "Play" and "stop" functions. I remapped these myself according to the defaults in the manual. No problem really there.
Other issues include the track selection 4 knob not responding at all even when remapped. Works if I clear mapping and make it do something else. Also the LED ring lights do not all function the same. 1&2 are full circles (as expected) but the other 6 are all only partials. I cannot find where I can edit the device mapping to fix these things as there are no default devices anywhere I can locate.

I have one infinite rotary knob (cue_vol) which I used to use as a jogwheel in Vdj7 but it will not respond to mapping it as such now. I cannot seem to map jogwheel to either of my controllers. Akai APC40 and Behringer CMD DC-1. The DC-1 having an entirely different set of mapping issues ranging from defaults missing buttons to mapping not responding properly.

I spent a very long time designing and coding my custom template for my APC40 and am beyond disappointed that I cannot get my mapping imported into VDJ8. I put my definition file and mapping xml into the same folder they were in on 7. I was able to turn off the default controller listing for vdj8 and it "sees" my controller definition (button namings are completely different so I know it's my definition) but it does not see my custom template.
I'm ok if I'm not able to utilize my older mapping since the new default has some tricks coded in that I am in love with. Mainly the paging stuff between sampler and pad functions. What I can't love with is the mapper not doing what it's supposed to. Even in default. Not sure if this is something I can edit myself or if it is on VDJ software side. If I have to just stick with 7 so I can have my controllers functioning properly than I will but I was really wanting to use the new system with all the new features. Please advise.

PS. I will bring up my other issues with the Behringer controller in a separate post.

Posted Sat 24 Feb 18 @ 3:42 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
...I put my definition file and mapping xml into the same folder they were in on 7. I was able to turn off the default controller listing for vdj8 and it "sees" my controller definition (button namings are completely different so I know it's my definition) but it does not see my custom template.

Are you sure VDJ sees your custom definition ? Do you see the Key names you have used ?
Since the APC40 is now natively supported in VirtualDJ 8, most likely VDJ will use the hardcoded one and not your custom. If you want your custom definition to take over, you need to rename it as force-whatevernameyouneed.xml

If you still have issues to load your custom definition and mapping file, then post here the first lines of your files, the <device> one and the <mapper> one, to take a look.

Posted Mon 26 Feb 18 @ 12:41 am