Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: VDJ Crash When Hotkey Played

This topic is old and might contain outdated or incorrect information.

So I have a nanokey2 korg that i mapped almost 2 weeks ago. Every time I go to press a button on it, vdj restarts.I have tried restarting my computer to make sure vdj is the only thing open and I also tried reinstalling vdj 8. Both things produced same outcome.

Posted Tue 09 Aug 16 @ 12:22 am
locodogPRO InfinityModeratorMember since 2013
show us a example of a mapping

Posted Tue 09 Aug 16 @ 12:39 am
play ? pause & pad 8 : pad 8 & key_lock & key -12

Posted Tue 09 Aug 16 @ 12:57 am
locodogPRO InfinityModeratorMember since 2013
and what is on pad 8

Posted Tue 09 Aug 16 @ 1:00 am
pad 8 is the hotkey to my cue point on track

Posted Tue 09 Aug 16 @ 1:03 am
locodogPRO InfinityModeratorMember since 2013
I don't see the nanokey2 as supported hardware, did you make the definition file yourself?

Posted Tue 09 Aug 16 @ 1:13 am
yes, I mapped the board myself. Each key has a value between -12 & 12 using the same mapping as above. Its just weird that i have been using it for 2 weeks and now have a problem with it.

Posted Tue 09 Aug 16 @ 1:20 am
locodogPRO InfinityModeratorMember since 2013
Ok we're diagnosing quite well, pc or mac and do you get the early access releases, and also have you updated recently?



Posted Tue 09 Aug 16 @ 1:29 am
I have pc (asus rog g752), as far as i know i don't get early access releases. The only new update I have is after i had reinstalled vdj hoping that would correct the problem.

Posted Tue 09 Aug 16 @ 1:40 am
locodogPRO InfinityModeratorMember since 2013

Posted Tue 09 Aug 16 @ 1:56 am
So that first one fixed it.

Posted Tue 09 Aug 16 @ 2:26 am
locodogPRO InfinityModeratorMember since 2013
That's good, I'm sure a member of the team will be along to request your definition file so they can figure out how to fix the problem.

Posted Tue 09 Aug 16 @ 2:43 am
In the mean while thank you for your help

Posted Tue 09 Aug 16 @ 3:30 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Which Pad Page is loaded when you get the crash ?
If its a custom one, can you share/post the content of the xml here ?

Posted Tue 09 Aug 16 @ 3:54 am
before i had downloaded http://virtualdj.com/download/virtualdj8/pc/3324/zip

it showed key cue mod. It now showes hotcues.

----------------------------------------------------------------------------------------------------------------------------------------------------------

the mapper xml for the controller?


<?xml version="1.0" encoding="UTF-8"?>

-<mapper date="2016-08-08" version="802" device="SIMPLE_MIDI_2372_277">

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -12 " value="0-BUTTON48"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -11" value="0-BUTTON49"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -10" value="0-BUTTON50"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -9" value="0-BUTTON51"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -8" value="0-BUTTON52"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -7" value="0-BUTTON53"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -6" value="0-BUTTON54"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -5" value="0-BUTTON55"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -4" value="0-BUTTON56"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -3" value="0-BUTTON57"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -2" value="0-BUTTON58"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key -1" value="0-BUTTON59"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key 0" value="0-BUTTON60"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +1" value="0-BUTTON61"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +2" value="0-BUTTON62"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +3" value="0-BUTTON63"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +4" value="0-BUTTON64"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +5" value="0-BUTTON65"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +6" value="0-BUTTON66"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +7" value="0-BUTTON67"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +8" value="0-BUTTON68"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +9" value="0-BUTTON69"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +10" value="0-BUTTON70"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +11" value="0-BUTTON71"/>

<map action="play ? pause & pad 8 : pad 8 & key_lock & key +12" value="0-BUTTON72"/>

<map action="loaded ? pause ? cue ? on : blink 800ms : on : off" value="0-ENCODER64"/>

</mapper>

Posted Tue 09 Aug 16 @ 11:30 am
locodogPRO InfinityModeratorMember since 2013
I see now,
you've got a conflict between your mapping and what's on the pads, mapping says one key and press a pad and then if the pads page is on keycue or KeyModPlay it demands another key.

If you change all your mapping from pad to hot_cue like so

play ? pause & hot_cue 8 : hot_cue 8 & key_lock & key -8

you can be up to date
Although you are using your HW in a limited way but that's up to you.
I'd look up editing pads pages.

Posted Tue 09 Aug 16 @ 11:49 am


(Old topics and forums are automatically closed)