Forum: Old versions

For older version, like VirtualDJ 7.


NOTE: VirtualDJ 7 is not maintained anymore.
Topic: Mic producing echo only in master/headphones
Hey folks,
I'm a low level user home user, have a very simple setup.

Heil PR40 connected to Alesis Multimix 8 usb fx. Controller is not in use at this time as I can't feet XLR to it, but I will be switching once I figure out what is causing this issue.

Anytime I use my mic I get an echo/almost latency/doubling up of my words in my ear. Out to the server I broadcast to, they don't hear this, and my recordings also come back normal (no echo). In my Windows setup the soundcard (the multimix) is not set to be listened to, and using other programs (SAM Broadcaster for ex) I do not receive an echo. I'm curious as to what setting I need to tweak here to make that echo disappear or even drop out my mic from my ears just for the sake of not stumbling over top of myself.

As of now my master is my main soundcard, mic is using the Multimix XLR input. As it stands I'm using VDJ 8 Pro. I also have 7 installed. Win 7 64. No standalone drivers for the Alesis. WASAPI for both cards.

Any ideas?
Devin

Posted Sun 18 May 14 @ 11:28 am
It's probably caused by the latency of the Alesis (delaying the mic signal into VDJ) on top of the latency of your output soundcard.

If neither of them are low latency ASIO then they'll be causing delays.

Posted Sun 18 May 14 @ 3:33 pm
That's about what I was thinking. Any quick and dirty way around it? It's not completely detrimental, just an annoyance.

Posted Sun 18 May 14 @ 7:00 pm
Only way to cure latency is to buy a more professional audio interface.

Get one with some nice shiny XLR mic inputs and plenty of in/out channels and you're sorted for some time to come.

Posted Sun 18 May 14 @ 7:12 pm

Posted Sun 18 Dec 16 @ 11:38 pm
I'm sure he probably figured it out or gave up three years later.

Posted Sun 18 Dec 16 @ 11:45 pm
DJ UB44PRO InfinityMember since 2018
Would running a small soundboard help with this. Running a strait mic to my controler creates echos. But if I run my Controler through a sound board and have a mic on the sound board, no problems. So if I reversed that set up, small sound board with mic, to controller and controller to mains... would that eliminate echo? I’ll have to try but has anyone else done this?

Posted Sat 22 Dec 18 @ 8:26 am
DJ UB44PRO InfinityMember since 2018
user13552013 wrote :
Here is the answer and it works https://www.youtube.com/watch?v=ArogJnDx1Do


This deals with hearing your own voice in your head phones, but it does not help with echos.
Go into settings and put your mic on a different deck. This will allow u to also change your voice through settings on that deck. So if your using deck one and two, set up deck 3 for mic.

Posted Sat 22 Dec 18 @ 8:35 am
Please don't post in topics over a year old. Read the forum rules.


DJ UB44 wrote :
a small soundboard

You mean a mixer? Which one? Make and model.


DJ UB44 wrote :
my controler

Which one? Make and model.

As the earlier posts state, the solution is to use professional audio equipment designed for low latency.

Posted Sat 22 Dec 18 @ 8:41 am