Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Skipping or Stuttering VDJ 2021
So The specs of my laptop are the following.

ASUS ROG Strix G17 Gaming Notebook |
17.3'' QHD 165Hz AMD Ryzen 7 5800H |
RTX3070, 16GB DDR4, 1TB SSD | Windows 10
Home

Now I've been testing this out since upgrading from my dual core HP laptop
and the odd time when I'm listening to music on auto mix i hear a sound stutter or freeze occuring and i'm not sure how to resolve this... I don't want this happening at a gig or if i'm manually using my Denon MK2 Controller to load a track on deck 1 or deck 2 for a key moment song.

Now I am using the Denon DJ ASIO DJ Controller driver older version of the driver as the newest from denondj.com is not saving the EQ settings when opening and closing the program.

https://www.denondj.com/downloads-archives#mc6000mk2/

Firmware on the Denon MK2 is set to http://cdn.inmusicbrands.com/denondj/MC6000Mk2/FW_MC6000MK2_v1003_01.zip

And the driver is not the latest http://cdn.inmusicbrands.com/denondj/MC6000Mk2/Denon-DJ-MC6000MK2-Win-1.0.3.zip


These are my settings.



In virtual DJ 2021 these are my math settings under performance


Now I do apologize but i'm use to the VDJ7 and VDJ8 where I had no problems. A lot of new things have been added to VDJ and I'm a bit lost. I don't know if anyone else has had similar problems or not but i'd like to find a remedy to this.





Any help would be appreciated.
 

Posted Wed 21 Jul 21 @ 2:37 pm
I think you're using the wrong ASIO driver. Should be 1.0.3

Denon ASIO drivers don't play well with many laptops, so you can use WASAPI instead if needed.
 

Posted Wed 21 Jul 21 @ 2:46 pm
I don't understand what you mean by Denon ASIO drivers don't work well with many laptops... The laptop is literally brand new it shouldn't have a single issue.

The 1.0.3 driver doesn't work with it none of the mapped EQ settings stay like they do and what do you mean by WASAPI ? I was reading something about making the buffer size 1024 on the ASIO Controller Driver ... But honest I've never had an issue until the newer versions of VDJ have come out.

I should be more specific... when using the 1.0.3 driver
when I open VDJ my volume controls are max on master / the program and are not defaulting to 0 out so it matches my controller. Is there a way to tell what firmware your controller has on it? I updated its firmware long ago. Maybe that's why?
 

Posted Wed 21 Jul 21 @ 2:50 pm
TVD UKPRO InfinityMember since 2007
I just bought a £1300 laptop, having no end of issues with Denon asio drivers, skipping, jumping, pausing etc. Bought a Presonus 24c using as a usb sound card, bypassing my Denon so far so good. Denon drivers are so old , need updating But I never had an issue with MC6000 funny enough Time to look at Macs for me. Funny enough similar spec Lenovo Legion 5 AMD Ryzen 7-5800H 16GB 512GB SSD 15.6 Inch FHD GeForce RTX 3070 8GB Windows 10 Gaming Laptop, my 6 year old laptop had no issues with MC6000, not used with new PC so can't comment on that.
I noticed on new laptop Link State Power Management was set to maximum power savings, so turned off trying that as we speak
 

Posted Wed 21 Jul 21 @ 5:28 pm
TVD UKPRO InfinityMember since 2007
If it helps, I have disabled Nvidia HD audio, Realtek audio and Nahimic in sound-video in device manager, seems good now for 2 hours fingers crossed.
 

Posted Wed 21 Jul 21 @ 8:19 pm
I just need to do more testing and its very hard with my wife and toddler in the house lol. I like to jack the music up and shake walls. That's the only way i've been noticing the stuttering / freezing of a song... I've adjust that fade on auto mix as I thought that might be the cause. my buffer I set to 1024 but the performance , math / stems etc... all is new to me never used or see it before.
 

Posted Wed 21 Jul 21 @ 8:59 pm
TVD UKPRO InfinityMember since 2007
It is not stems causing it so skip over that. Put headphones on run on automix, now still going also disabled loads of background apps too. Turn stems off if you want to only use pre compute
 

Posted Wed 21 Jul 21 @ 9:22 pm
I'll continue messing with it but anyone else have anything similar happen?
 

Posted Thu 22 Jul 21 @ 3:28 pm
TVD UKPRO InfinityMember since 2007
I have installed new copy of win 10 21h1 update on another partition on another m2 drive so dual boot. Using one boot just for DJ work so stripped all the crap off it, optimised it all, set to 1024 asio latency, had running all day so far so good.
 

Posted Thu 22 Jul 21 @ 7:44 pm
So it was a PC problem then.
 

Posted Thu 22 Jul 21 @ 8:37 pm
TVD UKPRO InfinityMember since 2007
It is working round old outdated drivers on Denon and old Firmware. No such issues with Pioneer. Last updated 2016 . Pioneer update firmware and drivers unlike Denon who prefer to force you to buy poorly made prime 4
 

Posted Fri 23 Jul 21 @ 3:44 pm
TVD UK wrote :
poorly made prime 4

Not in my experience (over a year).
 

Posted Fri 23 Jul 21 @ 4:34 pm
So I thought I had this fixed but turns out no. It screws up randomly sounding like scrambled sound for a brief second or two. I don't know what to do... Denon MK2 latest drivers aren't working properly with VDJ I can't be having this happen during a key moment like first dance or anything like that... I don't know how to describe this... But I need some help.
 

Posted Mon 09 Aug 21 @ 1:17 pm
DjAkuAKuControlleristMember since 2016
TYE77920 wrote :
So I thought I had this fixed but turns out no. It screws up randomly sounding like scrambled sound for a brief second or two. I don't know what to do... Denon MK2 latest drivers aren't working properly with VDJ I can't be having this happen during a key moment like first dance or anything like that... I don't know how to describe this... But I need some help.


hello there.
i going to try tp help you because it happen to me before with the denon drivers.

-First i remove all the bloatware from my laptop, mean all the software who the manufacturer install on your pc to free some resources like time processor, ram, gpu ( Ryzen 5 3500u 8go ram)

i second you must to optimize by deactivate some services in windows like windows search, all the telemetry system like user experience.
If you have some knowledge about to do it manually (the best way) it's here: http://www.blackviper.com/service-configurations/black-vipers-windows-10-service-configurations/
Other solution is by a script and a .bat, really simply and efficient: https://freesoft.dev/program/117203524

-Third is about vdj itself and frankly it depend of your computer and your is quite good.
i post a screenshot for you to have an idea.

For the asio....denon suck for that i had the same problems with my mc4000 and mc7000, to avoid these problems, use Asio4All it can resolve lot of Asio problems: https://www.asio4all.org/

Try to do fist all the steps and do a feedback to affine the seetings if it's necessary.
regards, Aku.
 

Posted Mon 09 Aug 21 @ 9:03 pm
Can you show me how your setup is done on audio page?
 

Posted Tue 10 Aug 21 @ 12:15 am
DjAkuAKuControlleristMember since 2016
Hello!
May this screenshot help you :)
 

Posted Wed 11 Aug 21 @ 11:33 pm
I used the MC6000mk1 for a long time, and I suggest do as Kradcliffe said early in this thred.
Ditch the ASIO and go for WASAPI. I had NO issues with wasapi whatsoever with Denon stuff.

 

Posted Thu 12 Aug 21 @ 11:01 am
Absolutely. Some people think using the manufacturer drivers is the right thing to do but in this case its literally the worst.
 

Posted Thu 12 Aug 21 @ 1:05 pm
dmaxv1PRO SubscriberMember since 2015
I just bought the Asus Rog a couple weeks ago and I’m having the exact same problems. I’ll continue to troubleshoot during this holiday weekend between gigs. I’m glad I have a backup laptop.

 

Posted Sat 28 May 22 @ 6:15 pm