Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: Roland 505 DJ controller
I don't know if it's supposed yet but the Roland 505 is not working right like something wrong with the jog wheels when u scratch and release the scratch it not smoothe its like pauses like when u just touch the jog wheel but I am releasing the scratch just taking my finger off of it.and the fader when on scratch mode and u close the fader u still here the music .on full mode it better but if u higher the music u can still here it very low.i am righting this to give the heads up for the Dev team so they can look at those problem when they do fully support it.i tried it on serato and the 505 does not have these problem.

Posted Tue 27 Feb 18 @ 1:52 am

Posted Tue 27 Feb 18 @ 6:45 am
djdadPRO InfinityDevelopment ManagerMember since 2005
angelt99 wrote :
.... something wrong with the jog wheels when u scratch and release the scratch it not smoothe its like pauses like when u just touch the jog wheel but I am releasing the scratch just taking my finger off of it.....

When the Jog is released but still moving a bit backwards, VDJ needs to decide if you are done with scratching or doing a Backspin. Can you try with the Setting TouchwheelSpinThreshold to a higher value, like 1,0 or 2.0 or even 3.0 and see if its getting better for your mix style ?
If not improved and you there is an issue even when the Jog is not moving at all, then it could be a latency issue. Are you on Mac or Windows ? What is the latency set to ? (from ASIO panel on Windows or the Latency VDJ setting on Mac)

angelt99 wrote :
...and the fader when on scratch mode and u close the fader u still here the music .on full mode it better but if u higher the music u can still here it very low....

When Crossfader is closed, can you put mouse over the Crossfader on the GUI and see what the Tooltip reports as value ?

Posted Tue 27 Feb 18 @ 7:19 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Ok, there seems to be some hardware/firmware fault here. The Crossfader on both DJ-505 and DJ-202 are 14bit and when at 100% (right side), both bytes should offer x7F value. But for some reason, the LSB is stopping at x70, so the VDJ Crossfader never reaches the absolute end.
We thought that this had to do with our own units only, but since its reported from others already, it seems that affects all of them, or at least a big production range.
We added some parameter in the definition to set the maximum position at an earlier value, and seems to be working fine now.
This change/fix will be available in next Early Access Build, whenever that comes.

In the meantime, what you can do is to change the mapping of the Crossfader from..
crossfader
to
param_multiply 1.01 & crossfader

Posted Tue 27 Feb 18 @ 8:11 am
Roland DJ-505 firmware and drivers up-to-date along with Virtual DJ. I even turned on the Early Access Build option. Restarted my MacBook Pro and tested another controller (Vestax VCI-380), which works great in Virtual DJ.

The issue is that the TRS part doesn’t work when pressed and I noticed the slicer making loops instead of showing the lit up pad going in progression.

I have yet to test this in Serato, but I know you guys just made it compatible. Are there still bugs that need working out in Virtual DJ?

Posted Thu 24 May 18 @ 2:50 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
There was indeed an issue with the TRS on Mac. A fix is pushed.
To get the fix..
- Open VirtualDJ (while your computer is connected to the Internet)
- Wait for 1 minute - dont have to do anything - to silently download the patch-fix
- Close VDJ and then open again.
- Make sure the "factory default" mapping is selected in Controllers tab of VirtualDJ settings.
To verify that you got the patch-fix, you should see a controllers.dat file in /Devices folder and your Build number should be 4291.1424

For Slicer, I don't understand what u mean and works fine here, but perhaps you have the "Step" Parameter to a value not equal to 1 beat and seems like its "looping" fast ?
BTW, Slicer mode is SHIFT+ROLL-SLICER button.
2nd press of ROLL-SLICER button offers the Loop page http://www.virtualdj.com/manuals/hardware/roland/dj505/layout/pads.html

Posted Thu 24 May 18 @ 5:10 pm