Forum: Old versions

For older version, like VirtualDJ 7.

NOTE: VirtualDJ 7 is not maintained anymore.

This part of topic is old and might contain outdated or incorrect information

russgPRO InfinityMember since 2010
I have Virtual DJ Version 7.0.5 Pro.
I have been using it now for a couple of years with no issues whatsoever. All of a sudden, about 2 weeks ago, when I am playing a song on 1 deck, I load a song onto the other deck, and when I hit play, the slider on the pitch changes and the song is either playing faster or slower.
It's not every song, it's random. I need the pitch slider to stay in the middle unless I change it myself. I'm not using the sync or anything of that sort. I thought the problem would correct itself when I shutdown and rebooted but it happened again last night. I have the auto pitch matching and the pitch reset on load both on disabled.

Posted Sat 05 May 12 @ 9:18 am

Posted Sat 23 Jun 12 @ 4:23 pm[ selected best answer by locodog on Tue 07 May 19 @ 4:29 pm ]
Sounds like you have smart play locked on.

Load the default skin (if you are not using it at present) and there will be a yellow padlock beside one of the play buttons. Click to unlock it and smart play will turn off.


Posted Sat 05 May 12 @ 9:56 am
russgPRO InfinityMember since 2010
OK, I am using the default skin. I see that there is a yellow or orange lock next to the slider for the pitch. Both decks have it. If I put the cursor on it, it says Pitchlock.
There is also a lock on both decks above the PLAY arrow and it says DECK ONE SMART PLAY AND of course deck 2 says the same except it says deck 2.
And while we are at it, There is also a lock on both decks for smart looping.
Now when I try to click on any of these locks, nothing happens.
There must be a key or something to unlock these. I never had them there before.

Posted Sat 05 May 12 @ 12:33 pm
russgPRO InfinityMember since 2010
Still looking for a solution. Anybody know how to correct my problem. Thanks

Posted Mon 07 May 12 @ 9:58 am
willkPRO InfinityMember since 2005
So what your saying is that your smartplay locks on each of your decks are engaged? The locks are an orange/yellowish color? If so, your right, they are in the " on " position. You SHOULD be able to just click them to disengage them. When in the " off " position, they will be grey. The only locks i have On are the keylock ( above the pitch slider on the default skin ) and the loop. If you cannot disengage the smartplay locks, then there's something very strange going on that needs to be addressed by the dev. team. or customer support.

Posted Tue 08 May 12 @ 5:39 pm
russgPRO InfinityMember since 2010
Yup, that's the problem. They don't unlock and that causes a major problem because when I start the song on deck 2 it adjusts the pitch slider up or down. Big hassle. Thanks for your input but again, need a developer to reach out. Thanks

Posted Tue 08 May 12 @ 6:04 pm
Any other solutions (already tried the one's above) to this issue....I have the same thing going on here too!!!


Posted Sat 23 Jun 12 @ 3:59 pm
I have the same problem except it only happens when I'm using timecodes. Rather I'm using my 1200's with Serato Timecodes or my CDJ's with Serato Timecodes. I'm using the Numark Connectiv sound card. When I use my Hercules or my Numark NDX-800's in Midi Mode I don't have that problem. It's only when I use timecodes. I even disabled the pitch in the debug box. The only things I have enabled is Smart Cue & Smart Loop. When I move the pitch a little bit, the pitch on the skin either goes all the way down or all the up relative to which way I move the slider. I was at home and the pitch went as high as 400 bpm's and as low as 20 bpm's as an example. Any suggestions?

Posted Sun 22 Jul 12 @ 9:01 am
iflandPRO InfinityMember since 2012
Hallo Zusammen,
ich nutze seit Kurzem Virtual DJ Pro v7.0.5b gemeinsam mit einem Controller/Mixer von Denon, DN -MC 6000.
Alles funktioniert bis dato einwandfrei, ausser ein nerviges Problem:
Der Volume-Fader von CH2 des Controllers steurt den Volume-Fader CH3 in der Software(auf dem Display) an, währen der
Volume-Fader von CH3 des Controllers den Volume-Fader CH2 in der Software (auf dem Display) ansteuert.
Wer kann mir helfen und vor allem wie?

Vielen Dank im Voraus!

Sorry, this forum is for English language messages only.

Please either post your message again in English or post in the appropriate language forum at the bottom of

Posted Sun 29 Jul 12 @ 12:05 pm
Experienced this before a gig yesterday. For me it was the "smartplay" feature. Try loading a diffrerent skin, turning it off, then going back to the skin you prefer.

Hope it helps.


Posted Sun 29 Jul 12 @ 1:37 pm
Hey players ! I just had the same problem useing rane SL2 timecodes. I went config /Info and clicked on reset fatory defalts. It fixed the problem for me...Good luck !

Posted Tue 07 Aug 12 @ 1:08 pm
I have had this happen to me recently. When I load a song on deck 2, it will automatically beat match to deck one. I have a temporary fix. Open up the file info of the song you'll be placing on deck 2. Erase the BPM info and click apply. Now when you load the song, the BPM won't change. Now to set up my system and find the real solution...

Posted Mon 19 Aug 13 @ 12:56 pm

Posted Mon 19 Aug 13 @ 2:34 pm

Thank you support staff… The link that you posted regarding soft-takeover is exactly what I needed… Pitch_relative is what I wanted. Thank you!

Posted Mon 02 Sep 13 @ 3:55 pm
Go to settings in upper right, click options then advanced options in upper right, in search box type auto, scroll down to audio and select autobpmmatching and select no. Type pitch, reset pitch on load. yes

Posted Thu 11 Sep 14 @ 7:27 pm
locodogPRO InfinityModeratorMember since 2013
Stop bumping years old topics.

Posted Thu 11 Sep 14 @ 11:10 pm
Thank you djmattnkat , saved the day mate :-)

Posted Thu 11 Jun 15 @ 12:36 pm
im trying to play my music but its not playing.i have tried turning the sound up but it keeps on saying error on the decks

Posted Sun 26 Jul 15 @ 3:23 am
That's usually because VDJ can't find the file. Are you loading from an iTunes playlist by any chance?

You need to make sure the file is still located where the playlist (or VDJ database) thinks it is.

Any moving or renaming of files needs to be done from within VDJ otherwise the location & name stored in the database will be wrong - causing problems like this.

By the way, in future please try to avoid posting in unrelated threads.

Posted Sun 26 Jul 15 @ 6:56 am
Page : [>] [>>]