VDJPedia



 Why do I get an error message saying that VirtualDJ is not supported on my architecture

Q. Why do I get an error message saying that VirtualDJ is not supported on my architecture?


This is because you are trying to install the software on old hardware that is no-longer supported.

VirtualDJ 7 requires a Mac with Intel processor running MacOS Leopard (10.5) or later.

If your computer has a PowerPC (PPC) processor, you will need to purchase a new computer if you wish to use VirtualDJ. This obsolete hardware is no-longer supported by VirtualDJ and the latest versions of many other applications.

If your Mac has an Intel processor but is currently running MacOS Tiger (10.4), then you will need to upgrade your operating system to MacOS Leopard (10.5) or later.




FAQ Knowledge Database Wiki HOME