Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: **URGENT** Major problem with Denon mc7000
Hi Guys,

i have just purchased a Denon mc7000. I run the latest version of Windows 11 Home, The latest VDJ 2021 build and have the latest 0.30 firmware installed on the controller and the latest drivers direct from Denon. When i go in to virtual dj it recognises my controller and i click denon mc7000. The mapping recognises my controller and the audio section seems to have all the right configs. However, I can use the toggle and panel buttons to go between folders and select pre listen and here all the music perfect through pre listen on the controllers but non of the jog wheels, pads, play, stop, loop buttons or any of the level nobs work or light up. Top half of the conroller has lit switches like the mic effects, deck select, but none of the bottom lights and as i say i cant press play or use any level knobs but it does recognise the cross fader. I used to run a pioneer DDJ SX2 on my virtual dj and i notice some mapper keys say pioneer, like play button is stated as pioneer? not sure if that has anything to do with it. I have not uninstalled and reinstalled vdj yet though.

I have tried everything, reinstallation of drivers, different usb cables, still the same. I actually have a radio show to get out so any urgent help would be really appreciated, thank you.

Posted Thu 20 Jan 22 @ 2:44 pm
I own a MC7000, but don't recognize the problems you are having
Is there anything specific you want me to test?
I'm on Windows 10, though, but I can't imagine how Win11 could affect just the lower half of a controller

Posted Fri 21 Jan 22 @ 9:24 am
I did da a video on my MC7000 a while back, but I'm not sure if anything in there shows how mine is acting differently than yours:

Posted Fri 21 Jan 22 @ 9:25 am
I have owned my Denon MC7000 Controller for around 3 years and never had any problems like you are experiencing.

I did notice your reference to your latest firmware and didn't recognise it. A quick check of the DenonDJ website and this is the firmware (v1.2) that I installed 3 years ago in my MC7000;

Go here


Posted Fri 21 Jan 22 @ 9:41 am
So, did this fix your ***Urgent*** problem?

It would be nice to hear some feedback.

Posted Sat 22 Jan 22 @ 8:51 am