Forum: VirtualDJ 8.2 Technical Support

Use this forum to report any bug, questions or comment related to the latest version of VirtualDJ 8.2.

(NOTE: VirtualDJ 8.2 is continuously updated, so many older topic on this forum are most probably already fixed in the current build)
Topic: Pioneer DDJ-SZ2 Mapping Issues
I have the Pioneer DDJ-SZ2. I am running Macbook Pro i7 with Virtual DJ 8.2 b3967. I'm having Mapping problems, every time I hit the Pitch Rest in Virtual DJ or Hold the Key Lock button on the DDJ-SZ2 the music cuts in & out, or if I manually move the Pitch slider slow back to zero the music will cut in and out. Can someone please help me with this mapping problem on the DDJ-SZ2. Thank You

Posted Mon 06 Nov 17 @ 5:38 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Do you also see CPU meter going to red during pitch resetting ?
What do you have for PitchQuality in VDJ Options ? Do you get the same issue if set to 1 or 2 ?

Posted Mon 06 Nov 17 @ 5:49 pm
The meter does not go to the red. I changed the pitch quality to 1,2,3 and still having the same problems.

Posted Mon 06 Nov 17 @ 5:55 pm
What is your latency set to? There have been many posts here in the past from people using Pioneer controllers with Macs, having audio glitches.

Certainly one that I recall was due to having latency set too low.

Posted Mon 06 Nov 17 @ 7:20 pm
My Latency is set to auto...

Posted Mon 06 Nov 17 @ 8:21 pm

Posted Mon 06 Nov 17 @ 8:52 pm
Thank you for the Link to see what my Latency is set at, But that is only for Windows users I'm on a MacBook Pro i7.

Posted Mon 06 Nov 17 @ 10:32 pm
Have you download and installed the drivers for SZ2 from Pioneer website ?
If no, please do so. If yes, please post here screenshots of the drivers tab pages

Posted Mon 06 Nov 17 @ 11:16 pm
I can not add pic on the form, it does not give me the option to upload. I have the latest driver installed and firmware, it was the first thing I did. I can have a friend upload a pic for me.

Posted Tue 07 Nov 17 @ 12:08 am
from DJ Reign

Posted Tue 07 Nov 17 @ 12:13 am

Posted Tue 07 Nov 17 @ 12:13 am

Posted Tue 07 Nov 17 @ 12:31 am
groovindj wrote :
What is your latency set to? There have been many posts here in the past from people using Pioneer controllers with Macs, having audio glitches.

Certainly one that I recall was due to having latency set too low.


we reset the latency to 832. We don’t know if it working 100% yet. The latency did fix the song cutting in and out but the random Weird stuff that it does we will test this week and let you know

Posted Wed 08 Nov 17 @ 5:52 am