Forum: Old versions

For older version, like VirtualDJ 7.

NOTE: VirtualDJ 7 is not maintained anymore.
Topic: Serial Number wont work.
Hi guys, so I just switched over to a new computer since my old laptop broke.

I tried installing the vestax typhoon version of virtual dj today and Everything Went fine until it asked me to give me the serial number. I looked at the back of my typhoon and I typed in the serial number. Heres the problem:Virtual DJ says that the serial key is invalid. I've tried uninstalling it and using I as 1 or 0 as O but that didn't work. Any suggestions.

Posted Mon 27 Apr 15 @ 12:22 pm
The number on the back of the Typhoon is most likely to be the serial number for the Typhoon, not VDJ.

Also, you don't appear to have registered your "Typhoon version" of VDJ to your account - it only shows you as a Home user.

If you had registered it here, you could have accessed the serial number from your account page....

Posted Mon 27 Apr 15 @ 12:39 pm
Thank you sir. Is there anyway I can use vdj 8 for my Typhoon or do I need to buy the new update?

Posted Mon 27 Apr 15 @ 3:09 pm
locodogPRO InfinityModeratorMember since 2013
Update, I doubt there be any Vestax V8 LE releases.

Posted Mon 27 Apr 15 @ 3:17 pm
My serial number works but my But VDJ states that my ASIO4ALL Driver does not have enough channels.
How do I fix this issue? Do I download a new driver? If so where?
If I have you reconfigure something..what and where?
Have had my vestax typhoon for a day and registered my serial number but am unable to use it with VDJ LE as yet or anything for that matter!!
Help I'm desperate at this stage,have used vdj free home version for a few years now and finally bought a mixer but can't use it!!!

Posted Tue 25 Aug 15 @ 12:22 pm

Posted Tue 25 Aug 15 @ 12:31 pm
I have a vestax typhoon and my serial number is invalid and I don’t know what to do

Posted Sun 04 Feb 18 @ 5:48 am
Please read this whole thread, and if you still have an issue, contact support, thank you.

Posted Tue 13 Feb 18 @ 8:14 pm
Also facing the same problem. i have also downloaded the ASIO4 but its still not working

Posted Sun 02 Sep 18 @ 10:26 pm