Forum: VirtualDJ 7 Technical Support (PC Version)

Use this forum if you have questions or difficulty with VirtualDJ 7 on Windows.


NOTE: VirtualDJ 7 is not maintained anymore.
Topic: ASIO problem - Not enough channels
Hi there,

Just looking for advice or if anyone else has come across the same problem I am having. I am currently using VDJ version 7 and have recently purchased a Hercules Deejay Trim 4&6 to use with my Technic 1210's. Since installing I have been experiencing the same problems without any joy of changing settings.

When I click to open VDJ I am getting a 'Error in the ASIO sound driver'
When I try to configure the input as 2 timecodes, output as 3 line mixer, unable to change the sound card from asio I get an 'Error not enough channels in Asio'

Some advice would be much appreciated,
Many thanks

Dean

Posted Wed 24 Jul 13 @ 11:39 am
DJ PhatsoPRO InfinityHercules Support TeamMember since 2005
First off, look at the audio configuration you've selected in the DJ Trim Control panel.

You have the choice between

- 4 In/ 4 Out : in other words 2 Stereo pairs for input and 2 Stereo pairs for output

- 2 In/ 6 Out : 1 Stereo pairs for input and 3 Stereo pairs for output.


Now let's look at the audio configuration you are trying to select in VDJ:

- 2 Timescodes = For which you would need 4 Inputs

- 3 Line Mixer = For which you would need 6 outputs


So VDJ basically tells you that you don't have a 4 Inputs/ 6 Outputs audio interface. :-)

Select External Mixer for Outputs and you'll be fine.

Posted Wed 24 Jul 13 @ 2:39 pm
Thanks for the advice Phatso.
Im currently looking at the configuration settings. Im unable to select 4in/4out on trim config so still have 2in/6out selected.
When I changed the vdj config to external mixer output it still shows 'error in asio sound driver: not enough channels.

Posted Wed 24 Jul 13 @ 3:02 pm
That's probably because you've still got timecodes selected as input. You don't have enough input channels (with 2 in/6 out) to use timecode for two decks.

Posted Wed 24 Jul 13 @ 6:08 pm
How do I get around this?

Posted Thu 25 Jul 13 @ 1:07 am
Do you really need to ask?!

See the first answer from DJ Phatso. I'll explain again in case you didn't get it....

Using time code requires two stereo inputs (i.e. "4 in"). The only way your interface provides "4 in" is when you select "4 in / 4 out".

So......if you want to use timecode inputs, you cannot select "3 line mixer" as your output setting.




Posted Thu 25 Jul 13 @ 2:53 am
djdadPRO InfinityDevelopment ManagerMember since 2005

Posted Thu 25 Jul 13 @ 3:56 am
Groovindj I was giving the wrong advice when I bought the deejay trim and told to use the 3 line mixer as output. Since Phatso pointed that mistake out I have changed the output to external mixer. I am not able to change the config to 4in/4out and hence still getting the not enough channels erroe message. I now understand why it is giving me the message just dont know why I cant select 4in/4out

Thanks for the link djdad ill give that a read and have another go

Posted Thu 25 Jul 13 @ 4:18 am
Look on page 14 of that manual. You'll see there's an option on the DeeJay Trim control panel to switch it to 4 in/4 out mode.

Important lesson: Always read the manuals for the products you own, so you know how they work. :-)

Posted Thu 25 Jul 13 @ 4:33 am
DJ PhatsoPRO InfinityHercules Support TeamMember since 2005
groovindj wrote :
Look on page 14 of that manual. You'll see there's an option on the DeeJay Trim control panel to switch it to 4 in/4 out mode.


And this needs to be done while VDJ is not running.

Posted Thu 25 Jul 13 @ 5:40 am
Thanks Phatso I now have it all up and running

Posted Thu 25 Jul 13 @ 1:55 pm