Forum: General Discussion

Discussions about VirtualDJ, and about DJing in general

Forum Guidelines
If you need extended support, contact our Support Team.
(*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: Numark Mixtrack Pro Setting up to an Amp
Hello-

I just bought a small DJ set up for a yearly summer party that I have. I bought A Numark Mixtrack Pro with Virtual DJ LE, Technical Pro LZ2200 Watt amp, and two Technical Pro Passive speakers.

I'm having trouble getting sound out of my speakers, and i'm new at all of this so I'm wondering if I'm missing something, or need different wiring. I can hook my PC up to my Mixer, and plug my mixer into my TV to hear my music no problem. I can also hook this set up to my house receiver, which is plugged into my surround sound and get music as well, But for the life of me I cant get music to come out of my Technical pro speakers.

This is how I have it set up:

1. Plugged Mixer into PC
2. Took an RCA cable that goes two males into 1 male. Plugged the two male side into the output jacks on the mixer, and plugged the other side with the one male end into CH-A input on my amp.
3. I bought banana clips for my speaker wire, so I could connect my speaker wire into my amp because it has banana posts.
4. Ran the speaker wire from the amp into my speaker. The speaker doesnt have banana posts, it has the push button clips where you just push down and insert a little bit of bare wire.

There is no sound coming out.

The back of the amp is set up like this;

Stereo/Bridge Mono Switch (Set to bridge mono)
Life/Ground Switch
Speakon Outputs CH-B and CH-A
XLR Inputs
Jack Inputs CH-B and CH-A (Mixer is plugged into CH-A)
Banana Post Outputs
AC Input (Power)

Front has

Power Switch
CH-A Level Control (Turned up 1/4 the way just to test)
CH-B Level Control
Output lock (Turned off)

Now I only brought out one speaker to test this set up with, and it looked pretty simple on the instructions on how to set up one speaker. It says to have it on Bridge Mono, and shows the one sided male RCA cable going into the Jack Input CH-A, and then it runs into the Mixer output jacks. It shows one speaker connected to the positive side terminals only, and says to not use the negative terminals when the amp is being operated in brdige Mono mode.

I did this and I hear nothing coming out of my Technical pro speaker.

Am i doing this wrong? And need different wiring?

Any help would be appreciated! Thanks for your time.

Posted Wed 18 Jul 12 @ 9:44 pm
Let me try to help.

First is a question. If you have 2 passive speakers why are you running your amp bridged?

Are you wanting to run in "mono" mode and parallel connect the 2 speakers? That could be an impedence mess for the amp to handle. And don't even try to series connect them. That won't work if the speakers have passive crossovers in them. What model Technical Pro speakers did you buy?

Stereo sounds so much better. Try the running the 2 speakers in stereo mode to see what happens.

Don't forget to turn your amp switch back to stereo mode. And connect your speakers with the red & black, left and right amp outputs.

Running an amp in "bridged" mode is best for subwoofers where you need max power. And you have to be very careful with impedences. I never run mine less than 4 ohms.

But I do buy amps that are good down to 2 ohms. Your Technical Pro is rated for 2 ohms so you have a decent amp.

If you want more bottom end then either get a powered subwoofer, or add another amp (larger one) and go with a passive subwoofer.


Good luck.

Jimmy






Posted Thu 19 Jul 12 @ 2:33 am
Hello-

As I mentioned I only dug one of my speakers out just to test if everything works well. I have it set to Bridge Mono because in the directions for the AMP it says if you want to run one speaker set it to Bridge Mono. I figured I must be missing something if this isnt working. I mean if you think that has something to do with it then I will dig my other speaker out, and try the stereo mode.

The Speakers I have are Cheap Technical Pro Speakers VRTX10 800 watts each.

Posted Thu 19 Jul 12 @ 7:26 am
Can you not get someone over to look at the setup for you and check that it's all wired correctly?

Family/friend/neighbor? Anyone that knows about wiring audio systems.

I mean it's much easier that way, because we can't see how you've set things up.

Posted Thu 19 Jul 12 @ 1:04 pm
There is no problem running one speaker on one channel of the amp. If you eventually intend on bringing out the other speaker then go ahead and wire as stereo.

If that test works... and you then only want to use 1 speaker in mono mode, then go ahead and use the 2 RCA to 1 adapter. And then bridge the amp for the extra power.

Choose which sound you like better. There are some situations where mono works out better than stereo... like in commercial installations where sound quality is not needed. But for DJing stereo is superior in sonic quality.

It's just a process of elimination to figure out why it's not working. Good luck.

Posted Thu 19 Jul 12 @ 1:56 pm
I ended up figuring it out nothing was wrong with my wiring everything works. There's just a key on the front of the amp that allows me to turn the Amp lock from off to on. And it was set to off, and I guess it's not supposed to be set to off, I turned it on and everything worked.

I do have another question though, after my test of one speaker I dug out the other speaker and set it up to Stereo instead of mono bridge. On the back of the Mixer I use both outputs correct? Output 1, and Output 2 to run both speakers?

I ended up putting an RCA cable into Output 1, and an RCA cable into Output 2, from there Output 1 runs into Channel A on the Amp and Output 2 runs into Channel B on the Amp, and then I set it to Stereo mode, and then plugged in both speakers. Does this sound correct? I feel like it's not very loud when I turned it all on. When I had it on Mono/Bridge with one speaker it was pretty loud.

Posted Fri 20 Jul 12 @ 1:16 pm
Did you not read any of the manual?

Output one is for the main mix, so you just plug one stereo RCA cable into that (red & white).

The red connection goes to the right channel input on the amp and the white channel goes to the left.

You don't need to connect output two to the amp. Output two is the cue channel (same as the headphones) for monitoring.

Posted Fri 20 Jul 12 @ 1:28 pm
One of the guys above posted about being careful with running a setup with too low of an impedence....I'm coming from more of a background understanding car audio more than pro sound setups (which I am just learning)......When setting up a bridged sub amp for a car, I routinely have seen guys wire stuff down to one ohm if the amp is rated for it. Is there any danger here, or is the only danger running an impedence too low when the amp isn't rated for it?.........Second question, how is this guy connecting the mixer to the PC?....Surely not off the 1/8th inch h. phone jack or usb?......thanks guys....


@ kristenl .......I would love to see posted pics of this setup and the connections if you could. Not sure if that is possible with no pro license though........

Posted Fri 20 Jul 12 @ 4:40 pm
jusblaze246 wrote :
running an impedence too low when the amp isn't rated for it?

Exactly. Most PA amps will run at 4 ohms per channel and no lower - meaning when they're bridged, the lowest load would be 8 ohms.

With most speakers that's fine - one speaker, bridged mode. Some speakers though are 4 ohms, so running one of those with the amp bridged would be a no-no.


jusblaze246 wrote :

how is this guy connecting the mixer to the PC


Kristen has a Mixtrack Pro....

Posted Fri 20 Jul 12 @ 6:34 pm
thanks groove! =D

Posted Fri 20 Jul 12 @ 6:48 pm
Some amps are capable of handling 2 Ohm loads per channel. So is this amp. But it is not recommended for any amp to use a 2 Ohm load. If anything happens on full power the least problem you can get is blowing a fuse. Also the heat dissipated is huge and will give you problems on a warm day. A 4 Ohm load per channel is the best to maximize the output. Bridging the amp means you'll get twice the power but the load has to be twice the minimum load per channel. So if a 4 ohm load per channel is recommended, a 8 ohm load in bridged mode is the minimum you can use.
With that in mind it is a normal thing to get more volume out of the amp in bridged mode (it is doubled). For use at home your setup will work because you won't run your setup on full power. But keep in mind that the amp is only 125 Watt RMS per channel. The 2x 1100 Watt that the amp can produce is the peak level at 2 Ohm load. The amp can do that for only a few milliseconds. An amp in this pricerange doesn't have the powersupply to be able to do that any longer.
So the famous advice would be: Get some gigs, save up for a better amp and speakers.

Posted Fri 20 Jul 12 @ 7:30 pm
If I plug the rcas into the main output on th mixer do I just pick one channel either A or B on the amp to run both speakers from? And leave it on stereo setting? Or do I have to plug one into A and one into B? I can take pics tomorrow. Thanks for the help as I am new at this and not trying to become a DJ just bought this for summer parties.

Posted Fri 20 Jul 12 @ 11:31 pm
Oh boy!

OK, the output from the Mixtrack Pro (output one) is stereo.....left and right.

That's why there are two RCA connectors. Red for right and white for left.

Your amplifier is also stereo. It has two channels.

Therefore you need to connect the red RCA cable to the right channel of the amp, and the white RCA cable to the left channel.

You have a cable that's got two RCA plugs at the Mixtrack end, and two mono jack plugs at the amp end, right?

Like this:
http://electromarket.co.uk/file/5sxRQwF/8cdafeb3-3df9-41b7-9d20-ddf240c9f75b.jpg



If the cable has two RCA plugs to only one (stereo) jack plug, then it's the wrong type of cable!

http://electromarket.co.uk/file/5sxRQwF/12eb7f45-175f-4a7d-b886-0175b8e5b718.jpg is the wrong type

If you only use one input of the amp, you will only hear half your music, in mono, from one speaker.

Oh, and one speaker needs to be connected to each output of the amp, and the amp needs to be in stereo mode (not bridged).


Posted Sat 21 Jul 12 @ 4:07 am
Tyren1PRO SubscriberMember since 2015
Howzit guys, i need some assistance please.

at the moment i am running wharfedale 215 impact speakers and i want to expand. i want to get a new amp and an 18 inch sub. what cables will i need for a crossover? my numark mixtrack pro 2 only has space for left and right output. i am using m RCA to f XLR. what splitter will i need?

Posted Wed 07 Feb 18 @ 6:24 am
What crossover? It all depends on the inputs and outputs of the crossover. Ideally, you would want to stick to a crossover that has XLR ins and outs. You would go into the crossover with the outputs from your controller, which is XLR. Out of the crossover with XLR to your two amps, out to your speakers with XLR.

Posted Wed 07 Feb 18 @ 7:32 pm