Forum: PC Version Technical Support - Topic: Using a mic in VirtualDJ

Use this forum if you have any question, bug, or technical difficulty with VirtualDJ on Windows.
Before posting, please read the FAQ.
(if you find bugs with the new VirtualDJ 8, please use the specific VirtualDJ 8 Bug Report forum).
VirtualDJ forums
PC Version Technical...
Using a mic in...


Author - Topic: Using a mic in VirtualDJ -

Emu76
Home user
Member since 2011

Posted Thu 14 Apr 11 @ 5:57 pm
I would have thought this had been discussed elsewhere, but after literally hours of searching I am just going to start a new topic, sorry if I am repeating a question asked many times before.

Virtual DJ 7 is causing me a major headache; in VDJ 6 there was the option to record Master+Mic when broadcasting, which was great because I could just switch my mic off when I didn't want it, and keep it hanging there. However, in VDJ 7, this option is gone, and now I cannot for the life of me get my microphone to work.

I don't actually have an external sound card in my computer, I simply used the rear audio outputs for the speakers, and the front panel connects the headphones and microphone. This worked fine in VDJ 6, and I don't see why there is a problem with it in VDJ 7. Now even when using an advanced setup and selecting the correct options, I either get static from my microphone, or my headphones don't work if I use the ASIO drivers. All I want is for all 3 to work as they should. It was possible in VDJ 6, and so I can't see any reason why it shouldn't work in VDJ 7. Any help in resolving this matter would be much appreciated.

DJTWalk
Home user
Member since 2010

Posted Sun 11 Sep 11 @ 12:22 am
I figured out how to record Audio and my Mic for my podcast. Its Pretty cool cause Change my voice and stuff. Here is how you do it..
1) Go to Conf Menu
2) In the Menu first got to Mappers and set up a way to turn on your mic. It should read Deck 2 linein 'mic' And pick something on your keyboard or audio board to turn it on. I used source 1 on my Hercules rmx Board.
3) Ok Here is the tricky part cause everybody keep telling me to to set it up in a way that only gave me audio and after playing around for three days I figured it out.
Go to Sound set up scroll down to advance conf and in that menu is where the magic begins:
You need to Master as your primary sound driver and that's an output next is optin is micrphone and that's an input
.

After that you can do so much with the mic and record its crazy!!! Have fun and I hope this helps

groovindj
PRO Infinity
Member since 2007

Posted Mon 12 Sep 11 @ 5:22 am
Emu76 wrote :
I don't actually have an external sound card in my computer

my headphones don't work if I use the ASIO drivers.



Why are you using ASIO drivers if you don't have a professional ASIO compatible sound card?

I very much doubt whether the sound built in to your computer is anything but consumer grade.

Either remove the ASIO drivers and use the standard Windows ones (or ones specific to your sound card) or buy a proper ASIO compatible card. :-)

afh-mp
Home user
Member since 2014

Posted Mon 26 May 14 @ 10:05 am
You could also install appropriate button on Mars, it should be easier to make a mix using microphone. It's a juke but you limited a very usefull function to just some hard configurations. I abandon this software.

djtouchdan
PRO Infinity
Member since 2008

Staff
Posted Tue 27 May 14 @ 6:01 am
This thread is 3 years old.

[closed]