Forum: PC Version Technical Support - Topic: Denon HC4500 ASIO Drivers

Discussions about the PC version of VirtualDJ, Numark Cue, Virtual Vinyl or AtomixMP3.
Hardware Support questions should be posted to the Hardware Technical Support forum. Before posting, please read the FAQ.
In case of problems or protection error please contact Service Support.
VirtualDJ forums
PC Version Technical...
Denon HC4500...


Author - Topic: Denon HC4500 ASIO Drivers -

craigalgar
PRO Infinity
Member since 2008

Posted Wed 18 Nov 09 @ 12:46 pm
Does VDJ 6.0.3 still not support the latest denon driver? I have tried it with a new install using windows 7 and I cant get the audio to work properly. The sound is choppy like you are flicking the volume fader up and down rapidly. I have installed the old ver1.01 driver and it works fine.I know this was an issue with VDJ 6.0.1 but I thought it had been resolved now? Just wondered if I have a problem or if it's just something the developers havent had chance to sort out yet.

djernie2
PRO Infinity
Member since 2009

Posted Wed 18 Nov 09 @ 9:19 pm
my denon asio drivers work just fine in 6.2 check out the download area. it has directions on updating denon drivers to work with vdj.

craigalgar
PRO Infinity
Member since 2008

Posted Thu 19 Nov 09 @ 3:09 am
Are you using the Denon ASIO 2 driver? My setup works fine, but only with Denon ASIO 1 driver. I will try ver 2 driver on mu Vista setup tonight to see if its a Windows 7 issue. Its not a big deal either way because I can still use ver 1 drivers with no problem. I only found this because i installed my HC4500 in windows 7 and had to install drivers from the Denon website which obviously defaulted to the latest versions, luckily I still had the install files on my hard drive from the vista installation

kradcliffe
PRO Infinity
Member since 2008

Posted Thu 19 Nov 09 @ 4:58 am
I don't think it matters whether you use Denon Asio V1 or V2, just choose which one works better for you. I have found I get far better latency from my crappy netbook than I get from my power laptop. With all these things it's just trial and error unfortunately!
Posted Thu 19 Nov 09 @ 4:54 pm
Read here for info about the drivers ... there is a difference ... http://www.virtualdj.com/wiki/DenonMIDISetup.html

djernie2
PRO Infinity
Member since 2009

Posted Mon 23 Nov 09 @ 10:49 pm
well i was wrong, i posted before i downloaded 6.3. after downloading 6.3 my asio drivers do not work, i have had to use my numark io for two shows now. i will have to go and figure out what needs to be down. It worked fine before the download.

craigalgar
PRO Infinity
Member since 2008

Posted Tue 24 Nov 09 @ 2:59 am
Use device manager to uninstall the drivers, then download and install the Denon 1.xxx ASIO Drivers. I think they're still available from the Denon website. If you can't find them just drop me a message and I'll e-mail them to you.
Since I've gone back to 1.xx everything has been fine....touch wood

djernie2
PRO Infinity
Member since 2009

Posted Tue 24 Nov 09 @ 12:31 pm
Yeah i will try that later tonite when i get home. will let you know the outcome. thanks

djernie2
PRO Infinity
Member since 2009

Posted Wed 25 Nov 09 @ 10:22 am
did not try it yet. family is in town for holiday and i may not get to it for a few days, but i will post when i get it done.

groovindj
PRO Infinity
Member since 2007

Posted Thu 26 Nov 09 @ 5:20 am
When is VDJ going to be fixed so that it works with the latest Denon drivers?

We should not have to be taking steps backwards.

cstoll
PRO Infinity
Member since 2004

Honorary Member
Posted Thu 26 Nov 09 @ 8:56 am
groovindj wrote :
When is VDJ going to be fixed so that it works with the latest Denon drivers?

We should not have to be taking steps backwards.


VirtualDJ works with both drivers ... however the limitations of some machines 'performance' capabilities is why some must use the 1.1 drivers vs the 2.0 drivers.

Also, the 1.1 drivers are the only 64-bit version drivers. And the drivers are DENON's, not VirtualDJ's. It's not our problem to fix - if there are problems that need fixing.

djernie2 wrote :
well i was wrong, i posted before i downloaded 6.3. after downloading 6.3 my asio drivers do not work, i have had to use my numark io for two shows now. i will have to go and figure out what needs to be down. It worked fine before the download.



And you will find that in the Denon MIDI Setup ... there are instructions to remove any other ASIO drivers from your system before you install the Denon drivers ... http://www.virtualdj.com/wiki/DenonMIDISetup.html

djernie2
PRO Infinity
Member since 2009

Posted Sun 29 Nov 09 @ 5:41 pm
Okay everything is fine now. I am running vista 64 bit, i uninstalled my denon 1.1 drivers and reinstalled from my denon installation disk and it is working in vdj 6.3, My denon firmware on the midi device is 1.6. now i want to upgrade from vista to windows 7 but i think i will wait until my xmas shows are done. just in case i run into any issues.

TimStatic
PRO Infinity
Member since 2009

Posted Tue 01 Dec 09 @ 10:49 pm
First post! Hello everyone. I have the Denon 2500 and using Dell XPS core 2 extreme 9000. I found out tonight as I am having issues with the driver. The only way I avoid the driver error message is to make sure the Denon is in Midi mode. Why is it that I can not use the Denon as the asio sound card for VDJ and still use the denon with my external hard drive? Why must it be in midi mode?

Any help would be great. If I am being vague I am sorry as I am new to the software. Using Vista Ultimate 32 bit.

Tim